ArcoLinux 19.09 iso has been released

[SOLVED] NVIDIA install on lenova all in one Solved

Post Reply
rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
[SOLVED] NVIDIA install on lenova all in one Solved

Post by rbrick49 » Fri Apr 13, 2018 3:23 am

Code: Select all

                                                 
           Mobo: LENOVO model: 3647 v: SDK0K13468 WIN 3273581860483 serial: N/A                     
           UEFI: LENOVO v: O29KT21AUS date: 06/30/2017                                              
Battery    hidpp__0: charge: N/A condition: NA/NA Wh                                                
                                                  
           hidpp__1: charge: N/A condition: NA/NA Wh                                                
                                                  
CPU:       Quad core Intel Core i7-6700T (-MT-MCP-)                                                 
           cache: 8192 KB                         
           clock speeds: max: 3600 MHz 1: 800 MHz 
           2: 800 MHz 3: 800 MHz 4: 800 MHz       
           5: 800 MHz 6: 800 MHz 7: 800 MHz       
           8: 800 MHz                             
Graphics:  Card-1: Intel HD Graphics 530          
           Card-2: NVIDIA GM107M [GeForce GTX 950M]                                                 
           Display Server: x11 (X.Org 1.19.6 )    
           drivers: nouveau,intel (unloaded: modesetting,fbdev,vesa)                                
           Resolution: 2560x1440@59.96hz          
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)                           
           version: 4.5 Mesa 18.0.0               
Audio:     Card Intel Sunrise Point-H HD Audio    
           driver: snd_hda_intel                  
           Sound: ALSA v: k4.15.8-1-ARCH          
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller                       
           driver: r8169                          
           IF: enp2s0 state: down                 
           mac: 98:ee:cb:51:e2:92                 
           Card-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter                       
           driver: ath10k_pci                     
           IF: wlp3s0 state: up                   
           mac: 94:e9:79:f4:3b:21                 
           Card-3: Qualcomm Atheros               
           IF: null-if-id state: N/A speed: N/A duplex: N/A                                         
           mac: N/A                               
Drives:    HDD Total Size: 1256.3GB (2.2% used)   
           ID-1: /dev/sda model: WDC_WD10SPCX size: 1000.2GB                                        
                                                  
           ID-2: /dev/sdb model: LITEON_L8H size: 256.1GB                                           
                                                  
Partition: ID-1: / size: 217G used: 9.8G (5%)     
           fs: ext4 dev: /dev/sdb2                
           ID-2: swap-1 size: 18.37GB used: 0.00GB (0%)                                             
           fs: swap dev: /dev/sdb3                
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: -0.0                                      
           Fan Speeds (in rpm): cpu: N/A          
Info:      Processes: 247 Uptime: 1:09 Memory: 2587.7/15923.9MB                                     
           Client: Shell (bash) inxi: 2.3.56  
this is the machine I have arcolinux running on but I cant find any info howto install nvidia bumblebee
Last edited by rbrick49 on Wed May 02, 2018 5:33 am, edited 1 time in total.
Australian living in Thailand

User avatar
darknetmatrix
Captain
Posts: 314
Joined: Tue Nov 07, 2017 3:47 pm
Contact:
Belgium
Re: NVIDIA install on lenova all in one

Post by darknetmatrix » Fri Apr 13, 2018 3:39 am

Install Bumblebee
On modern hardware, with current drivers:

Code: Select all

sudo pacman -S bumblebee mesa xf86-video-intel nvidia lib32-nvidia-utils lib32-virtualgl nvidia-settings bbswitch
On older hardware, with 340.xx legacy drivers:

Code: Select all

sudo pacman -S bumblebee mesa xf86-video-intel nvidia-340xx nvidia-340xx-utils lib32-nvidia-340xx-utils lib32-virtualgl bbswitch
On even older hardware, with 304.xx legacy drivers:

Code: Select all

sudo pacman -S bumblebee mesa xf86-video-intel nvidia-304xx nvidia-304xx-utils lib32-nvidia-304xx-utils lib32-virtualgl bbswitch
Add yourself to bumblebee group
Any user that is supposed to use Bumblebee must be added to this group. The user must also be a member of the video group - it is usually so by default, but not always.

Code: Select all

sudo gpasswd -a $USER bumblebee

Code: Select all

sudo gpasswd -a $USER video
Enable bumblebeed service
Notice the final d (from daemon) letter in the service's name.

Code: Select all

sudo systemctl enable bumblebeed.service
Finally there's the Arch-wiki about bumblebee: https://wiki.archlinux.org/index.php/Bumblebee
linux user # 527315
I never lose. Either I win, or I learn.

Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: NVIDIA install on lenova all in one

Post by rbrick49 » Fri Apr 13, 2018 3:50 am

thanks very much by the way this is a great operating system
Australian living in Thailand

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: NVIDIA install on lenova all in one

Post by rbrick49 » Fri Apr 13, 2018 7:57 am

no luck it keeps telling me bumblebee not running
Australian living in Thailand

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: NVIDIA install on lenova all in one

Post by rbrick49 » Fri Apr 13, 2018 12:51 pm

ok did some more trying to get bumblebee working found no key for nvidia-xconfig so not sure if thats throwing a spanner in the works
Australian living in Thailand

User avatar
erikdubois
Captain
Posts: 2387
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: NVIDIA install on lenova all in one

Post by erikdubois » Sat Apr 14, 2018 8:25 am

I quickly googled found this link https://hemenkapadia.github.io/blog/201 ... lebee.html

Maybe you need to blacklist nouveau.

Happy hunting.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: [OPEN] NVIDIA install on lenova all in one

Post by rbrick49 » Sat Apr 14, 2018 2:39 pm

one more try wish me luck
Australian living in Thailand

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: [OPEN] NVIDIA install on lenova all in one

Post by rbrick49 » Sat Apr 14, 2018 3:19 pm

ok thanks darknetmatrix and erikdubois the black listing nouveau did the trick
regards Ron
Australian living in Thailand

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: [OPEN] NVIDIA install on lenova all in one

Post by rbrick49 » Sun Apr 15, 2018 2:44 am

well nvidia-xconfig sent it to a black screen back to the drawing board
Australian living in Thailand

rbrick49
Crewman
Posts: 24
Joined: Thu Apr 12, 2018 8:10 am
Australia
Re: [OPEN] NVIDIA install on lenova all in one

Post by rbrick49 » Sun Apr 15, 2018 4:54 am

Card-1: Intel HD Graphics 530
Card-2: NVIDIA GM107M [GeForce GTX 950M]
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa,intel)
Resolution: 2560x1440@59.99hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
version: 4.5 Mesa 18.0.0
this doesnt look right to me instead of modesetting should that be nvidia
but I get this when running diagnostics

Code: Select all

[grumpy@ron-pc ~]$ optirun glxspheres64
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GTX 950A/PCIe/SSE2
229.740424 frames/sec - 256.390313 Mpixels/sec
233.301202 frames/sec - 260.364142 Mpixels/sec
233.722969 frames/sec - 260.834833 Mpixels/sec
232.284596 frames/sec - 259.229609 Mpixels/sec
231.880696 frames/sec - 258.778856 Mpixels/sec
234.261036 frames/sec - 261.435317 Mpixels/sec
228.877357 frames/sec - 255.427130 Mpixels/sec
231.592038 frames/sec - 258.456714 Mpixels/sec
228.104490 frames/sec - 254.564611 Mpixels/sec
232.062245 frames/sec - 258.981466 Mpixels/sec
230.272599 frames/sec - 256.984220 Mpixels/sec
230.279620 frames/sec - 256.992055 Mpixels/sec
230.923334 frames/sec - 257.710441 Mpixels/sec
231.718522 frames/sec - 258.597870 Mpixels/sec
231.453950 frames/sec - 258.302608 Mpixels/sec
233.604505 frames/sec - 260.702628 Mpixels/sec
230.551161 frames/sec - 257.295096 Mpixels/sec
229.401880 frames/sec - 256.012498 Mpixels/sec
224.299220 frames/sec - 250.317930 Mpixels/sec
222.197613 frames/sec - 247.972536 Mpixels/sec
223.580510 frames/sec - 249.515850 Mpixels/sec
228.996043 frames/sec - 255.559584 Mpixels/sec
Australian living in Thailand


Post Reply

Return to “Graphical Drivers (Nvidia,...)”