ArcoLinux -D -B 19.5 iso's have been released

[OPEN] Waiting 30 seconds for device /dev/disk/by-label/

arctic0
Crewman
Posts: 12
Joined: Wed May 22, 2019 9:45 pm
Afghanistan
[OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by arctic0 » Wed May 22, 2019 9:59 pm

Having exactly the same issue as: viewtopic.php?t=840 but with the difference that I can't enter anything once the rootfs prompt appears.

I tried to:
- compile it in arcolinux-awesome-minimal and then the full "regular" arcolinux
- a fresh git clone, without modifying anything of https://github.com/arcolinux/arcolinuxd-iso
- passthrough a gpu and "real" mouse+keyboard to the VM, instead of VNC

During the 30 script it only complains that it can't set the locale couple times and that some mountpoint in /work/ might be causing unexpected behaviour, nothing else.

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by erikdubois » Thu May 23, 2019 6:33 am

Try the different iso's we provide and not just the latest.
You can go back in time and you will have different calamares editions.
That might do the trick.
Often it is a usb stick problem like hardware (bad stick) or software (choose another application to burn the iso on the usb).
We use mintstick the application on ArcoLinux to burn it and etcher will work too on any Operating system.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

arctic0
Crewman
Posts: 12
Joined: Wed May 22, 2019 9:45 pm
Afghanistan
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by arctic0 » Thu May 23, 2019 7:05 am

I have not yet burned it to any USB, because I wanted to try the output in a VM/KVM first, booting the ready to download isos works no problem, yet the one I build with 30 all suffer from this issue.

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by erikdubois » Thu May 23, 2019 7:42 am

Any other pc to try it out... setting in vb you need to check ... see the articles on arcolinux.com to check the settings we use and you use.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

arctic0
Crewman
Posts: 12
Joined: Wed May 22, 2019 9:45 pm
Afghanistan
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by arctic0 » Thu May 23, 2019 6:13 pm

All the tutorials and videos I can find only show that you select the ISO, no other settings? could you please link me which specific settings you mean?

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by erikdubois » Thu May 23, 2019 7:07 pm

Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

arctic0
Crewman
Posts: 12
Joined: Wed May 22, 2019 9:45 pm
Afghanistan
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by arctic0 » Thu May 23, 2019 7:14 pm

Yeah, no settings were made that are out of the ordinary, I tried to set the iso to be as IDE too, but that didn't solve it. By the way, I am not on virtualbox but KVM and as mentioned also; the ready isos work, but when I try to build it with 30 right after the git clone, it produces the faulty iso for some reason, so what is different from the official isos to the ones that are produced by 30 (which are supposed to be exactly the same process?..)

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by erikdubois » Thu May 23, 2019 7:18 pm

then move to another forum
ArcoLinuxB forum with desktop you choose
give use the whole print out from the terminal
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

arctic0
Crewman
Posts: 12
Joined: Wed May 22, 2019 9:45 pm
Afghanistan
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by arctic0 » Thu May 23, 2019 7:29 pm

It is directly related to arcolinux?.. (I just want to build my own iso) here is the in OP mentioned errors though, the first one sounds like it might be the issue?

Code: Select all

==> WARNING: work/x86_64/airootfs is not a mountpoint. This may have undesirable side effects.

Code: Select all

bsdcpio: Failed to set default locale

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Waiting 30 seconds for device /dev/disk/by-label/

Post by erikdubois » Fri May 24, 2019 7:04 am

all good

give me ALL the code
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “BYOI ArcoLinuxD”