Page 1 of 1

[SOLVED] System won't update - libmozjs-52.so.0

Posted: Sat May 05, 2018 6:58 pm
by jasonleeg
Hi there, I've tried to update the system and I get an error message about conflicting files, the update aborts and none of the 41 items are updated. I've attached a screenshot of the error......so, how can this be solved.
Thank you for your help


Re: System won't update

Posted: Sun May 06, 2018 6:07 am
by Zver43
is it this error ?

error: failed to commit transaction (conflicting files)
js52: /usr/lib/libmozjs-52.so.0 exists in filesystem
Errors occurred, no packages were upgraded.
[foo@al661-vb-n750 ~]$

Fix is here ------ copied from https://www.archlinux.org/news/js52-527 ... ervention/ upgrade requires intervention
---------------------------------
2018-05-04 - Jan Steffens

Due to the SONAME of /usr/lib/libmozjs-52.so not matching its file name, ldconfig created an untracked file /usr/lib/libmozjs-52.so.0. This is now fixed and both files are present in the package.

To pass the upgrade, remove /usr/lib/libmozjs-52.so.0 prior to upgrading.
--------------------------

this means you must be Root to delete this file
i have done this on several machines and all works ...

Re: [OPEN] System won't update

Posted: Sun May 06, 2018 8:49 pm
by erikdubois
quite correct
thanks for responding :geek:

Code: Select all

sudo rm /usr/lib/libmozjs-52.so.0

Re: [OPEN] System won't update

Posted: Sun May 06, 2018 9:08 pm
by jasonleeg
Brilliant, this worked. Thank you both for your help.

Re: [SOLVED] System won't update - libmozjs-52.so.0

Posted: Wed May 09, 2018 6:01 pm
by erikdubois
To anyone who reads this :

Any future issues on your system.... then

First check Arch Linux @ https://www.archlinux.org/.

It is not the first issue nor will it be the last. But this website will tell if there is a problem and if there is a solution.

ArcoLinux is based on Arch Linux. This means that Manjaro, Antergos and any other distro will get the same message if the software is installed.