ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] Failed to run Redshift

First check the forums - Do not know where to put it then put it here
Post Reply
adarco
recruit crewman
Posts: 2
Joined: Tue Jul 17, 2018 12:54 pm
Portugal
[SOLVED] Failed to run Redshift

Post by adarco » Tue Jul 17, 2018 1:06 pm

So, you have been hit with the Redshift hammer?

The error is something like this:

"Failed to run Redshift
Trying location provider 'geoclue2'...
Waiting for initial location to become available...
Unable to start GeoClue client
GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: 'redshift' disallowed, no agent for UID 1000."

Open your terminal and type the following commands:

1. get the real location by using geoclue link that is already on your system
and look for a link like this: https://location.services.mozilla.com/v ... y=xxxxxxxx

Code: Select all

vim /etc/geoclue/geoclue.conf
You can double-click on it to open it on the browser or just copy-paste into the browser.
It will open a page with your geo location, so take note of two values:

lat: 36.0421
lng: -6.4945

Now, back to terminal and copy-paste these commands, to create the redshift directory,
edit the new config file and save it.

The text you will be putting on the redshift file is referenced on the Arch wiki page
and the link is https://wiki.archlinux.org/index.php/Redshift

But you can copy the text from the redshift git page:
https://raw.githubusercontent.com/jonls ... onf.sample

Now copy all the text on the web page and paste it onto the file you will be creating below.

Code: Select all

mkdir ~/.config/redshift
vim ~/.config/redshift/redshift.conf
sudo vim ~/.config/redshift/redshift.conf
This opens redshift.conf and you can paste all of the git redshift page here now.
Then look almost at the botton for this:

[manual]
lat=48.1
lon=11.6

Now, change those values for the values that you had taken note before on the Mozilla link.
Save the file, and open redshift again, so it can use this location.

User avatar
darknetmatrix
Captain
Posts: 289
Joined: Tue Nov 07, 2017 3:47 pm
Contact:
Belgium
Re: [SOLVED] Failed to run Redshift

Post by darknetmatrix » Wed Jul 18, 2018 4:10 am

great tip adarco!
linux user # 527315
I never lose. Either I win, or I learn.

Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.


Post Reply

Return to “General Questions”