ArcoLinux -D -B 19.11 has been released

[OPEN] Freezes after login. Not even access to TTY

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Sat Jun 22, 2019 2:53 am

erikdubois wrote:
Thu Jun 13, 2019 8:51 pm
TTY should be available at all time.

IF that is not possible.... reinstall.
Sorry for the delay. reinstalled it. Still not going.

Extra options to make it even boot:

Code: Select all

acpi_osi=! acpi_osi=windows nomodeset i915.preliminary_hw_support=1
Below what I get when trying to login via TTY.



Maybe this would be something happening with Noveau (there's a lot of Noveau messages in that screen)? How can I block it from starting?

Why does it work on live iso but doesn't work after installed? This puzzles me a lot.

User avatar
erikdubois
Captain
Posts: 2642
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Freezes after login

Post by erikdubois » Sat Jun 22, 2019 7:32 am

Did you check this thread?

viewtopic.php?f=133&t=1331&hilit=hybrid
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Sat Jun 22, 2019 5:32 pm

erikdubois wrote:
Sat Jun 22, 2019 7:32 am
Did you check this thread?

viewtopic.php?f=133&t=1331&hilit=hybrid
Yes. But my problem is that I cannot get into the shell because it freezes after login. So I cannot issue any command at all.

Is there any way to block nvidia driver load at boot? nomodeset seems not to do the deal too.

User avatar
erikdubois
Captain
Posts: 2642
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Freezes after login

Post by erikdubois » Sat Jun 22, 2019 6:09 pm

IF on hardware test this key combo

CTRL + ALT + F2

IF on virtualbox

RIGHT CTRL + F2

and report back
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Mon Jun 24, 2019 2:53 am

erikdubois wrote:
Sat Jun 22, 2019 6:09 pm
IF on hardware test this key combo

CTRL + ALT + F2

IF on virtualbox

RIGHT CTRL + F2

and report back
Nope. Didn't work.

Got the following on TTY2:



and after more or less half a minute got the following and stopped:



This computer has Windows 10 so it works. And also the live ISO works if I add

Code: Select all

acpi_osi=! acpi_osi=windows i915.preliminary_hw_support=1
but adding this to the installed version does not work at all.

Also tried Pop_OS! Nvidia ISO version (uses proprietary Nvidia drivers) and it works, so the issue should be with the damn Noveau driver.

Going to reinstall again (removed all non-windows files from EFI partition to be sure this would be a fresh install) and try adding also to the grub options this to see if it works:

Code: Select all

nouveau.blacklist=1
Is there any other way to block Noveau driver to load on boot via kernel options or otherwise? Just in case this attempt fails again.

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Mon Jun 24, 2019 6:28 pm

Some more news.

Tried again with Ubuntu 19.04 with Safe Graphics (in fact it's just nomodeset added to the grub line).

Installed. Booted ok. Installed NVidia drivers without asking. INXI results below.

Code: Select all

System:
  Host: OMEN-by-HP-Laptop Kernel: 5.0.0-17-generic x86_64 bits: 64 
  Desktop: Gnome 3.32.0 Distro: Ubuntu 19.04 (Disco Dingo) 
Machine:
  Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A 
  serial: <root required> 
  Mobo: HP model: 838F v: 40.28 serial: <root required> 
  UEFI: American Megatrends v: F.18 date: 11/09/2018 
Battery:
  ID-1: BAT0 charge: 34.5 Wh condition: 60.6/60.6 Wh (100%) 
CPU:
  Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  L2 cache: 6144 KiB 
  Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 801 5: 800 6: 801 7: 800 8: 800 
Graphics:
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 418.56 
  Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
Audio:
  Device-1: Intel CM238 HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.0.0-17-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: 48:ba:4e:47:eb:00 
  Device-2: Intel Wireless 7265 driver: iwlwifi 
  IF: wlo1 state: down mac: f8:34:41:a2:a9:45 
Drives:
  Local Storage: total: 1.03 TiB used: 8.67 GiB (0.8%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW128HEGR-000H1 
  size: 119.24 GiB 
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 56.85 GiB used: 6.86 GiB (12.1%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-2: /boot size: 595.2 MiB used: 113.6 MiB (19.1%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-3: /home size: 753.84 GiB used: 83.7 MiB (0.0%) fs: ext4 dev: /dev/sda3 
  ID-4: /var size: 10.51 GiB used: 1.59 GiB (15.1%) fs: ext4 dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 39 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 270 Uptime: 14m Memory: 15.54 GiB used: 1.19 GiB (7.6%) 
  Shell: bash inxi: 3.0.33 

User avatar
erikdubois
Captain
Posts: 2642
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Freezes after login

Post by erikdubois » Mon Jun 24, 2019 6:30 pm

Now we are getting somewhere.

Is it installed with grub? Since we have in the latest iso also the possibility to install with nomodeset.

What drivers for nvidia are installed afterwards?
Is the nouveau driver blacklisted?

Basically what happens on the backend to achieve it.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Mon Jun 24, 2019 9:53 pm

erikdubois wrote:
Mon Jun 24, 2019 6:30 pm
Now we are getting somewhere.

Is it installed with grub? Since we have in the latest iso also the possibility to install with nomodeset.
Yes. I tested starting the Ubuntu live ISO with nomodeset.
erikdubois wrote:
Mon Jun 24, 2019 6:30 pm

What drivers for nvidia are installed afterwards?
Is the nouveau driver blacklisted?
I think the NVidia installed is NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 418.56

How can I check this? :D

User avatar
erikdubois
Captain
Posts: 2642
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Freezes after login

Post by erikdubois » Mon Jun 24, 2019 9:57 pm

There must be a command for it on debian for sure.

nvidia-smi

modinfo nvidia

quick google search
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

lopoalmeida
Crewman
Posts: 47
Joined: Sat Sep 08, 2018 2:44 pm
Portugal
Re: [OPEN] Freezes after login

Post by lopoalmeida » Thu Jun 27, 2019 6:02 pm

erikdubois wrote:
Mon Jun 24, 2019 9:57 pm
There must be a command for it on debian for sure.

nvidia-smi

Code: Select all

~$ nvidia-smi
Thu Jun 27 16:59:21 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 418.56       Driver Version: 418.56       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1050    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   42C    P8    N/A /  N/A |    201MiB /  4040MiB |      7%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      2734      G   /usr/lib/xorg/Xorg                            85MiB |
|    0      2979      G   /usr/bin/gnome-shell                         111MiB |
|    0      5518      G   /usr/lib/waterfox/waterfox                     1MiB |
+-----------------------------------------------------------------------------+
erikdubois wrote:
Mon Jun 24, 2019 9:57 pm
modinfo nvidia

Code: Select all

~$ modinfo nvidia
filename:       /lib/modules/5.0.0-19-generic/updates/dkms/nvidia.ko
alias:          char-major-195-*
version:        418.56
supported:      external
license:        NVIDIA
srcversion:     AA5D9C867B6BC7FFD055995
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        ipmi_msghandler
retpoline:      Y
name:           nvidia
vermagic:       5.0.0-19-generic SMP mod_unload 
sig_id:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4

(...)
That's what I got on Ubuntu :)


Post Reply

Return to “Installation issues of ArcoLinux iso”