Page 1 of 2

[SOLVED] ArcoLinuxB-cinnamon+ login window

Posted: Wed Mar 27, 2019 4:17 pm
by unitymedia
Hello,
The following is striking when compared with other arch distros,
in the settings are missing, automatic log in, because I noticed there is missing login manger, with manjaro cinnamon it is there like the linux mint 19.1 or LDME 3, screenschots come from manjaro cinnamon, what do I have to do so that there arco cinnamon autologin.
Image

Image

Image

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Wed Mar 27, 2019 4:47 pm
by erikdubois
We have lightdm settings manager to set our login.

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Wed Mar 27, 2019 6:31 pm
by unitymedia
That's what Arco says


Image

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Wed Mar 27, 2019 10:24 pm
by erikdubois
Did you check if we are talking about the same software/application?

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Thu Mar 28, 2019 7:01 am
by unitymedia
How should I check it?
but pictures say a lot, because at Manjaro it's the same as original from Linux mint / linux debian mint,

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Thu Mar 28, 2019 10:06 am
by julientm
unitymedia wrote:
Thu Mar 28, 2019 7:01 am
How should I check it?
but pictures say a lot, because at Manjaro it's the same as original from Linux mint / linux debian mint,
Paste your getty configuration, so we can see what's wrong.


More info here. https://wiki.archlinux.org/index.php/getty

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Thu Mar 28, 2019 6:06 pm
by unitymedia
Here,

Code: Select all

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Thu Mar 28, 2019 7:26 pm
by erikdubois
I do not think there is anything wrong.
Just manjaro is different.

Why this getty?

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Thu Mar 28, 2019 8:21 pm
by unitymedia
Essentially, the cinnamon environment of manjaro is very similar to the original one, but getty is, I believe, responsible for autologin, which does not work and does not change graphically.

Re: [OPEN] ArcoLinuxB-cinnamon+ login window

Posted: Fri Mar 29, 2019 4:36 am
by julientm
I got it confirmed working on a xfce session.

1st step - open users-admin package by launching

Code: Select all

$ users-admin

If you do not have the package install it it's parent repo

Code: Select all

yay -S gnome-system-tools
Image

2nd step - Enable Don't ask for password on login parameter
*In Users Settings window click user
*then click change password
*then activiate Don't ask for password on login
Image

3rd Step - Add user to autologin group
*In user settings click manage groups
*in group settings click autologin
* then click properties
* then click on toggle box and add your user to the group.
Image

4th - Get session name Doc References 1
* Print session name

Code: Select all

cat ~/.dmrc
to get session name variable

5th - Edit /etc/lightdm/lightdm.conf
*

Code: Select all

sudo vim /etc/lightdm/lightdm.conf
Under [LightDM] make sure
run-directory=/run/lightdm
is uncommented

Under [Seat: *]
Uncomment

*pam-service=lightdm
*pam-autologin-service=lightdm-autologin
*pam-greeter-service=lightdm-greeter
*greeter-session=lightdm-gtk-greeter
*user-session=xfce
*session-wrapper=/etc/lightdm/Xsession
*autologin-user=julien
*autologin-user-timeout=0
*autologin-session=xfce
*exit-on-failure=false
my /etc/lightdm/lightdm.conf
https://gist.github.com/julien-tremblay ... ebc145997b


6th step - Edit pam /etc/pam.d/lightdm [url=https://wiki.archlinux.org/index.php/Li ... less_login]refdoc 2
Start pam

Code: Select all

sudo vim /etc/pam.d/lightdm
if you don't have pam install

Code: Select all

yay -S accountsservice

Image


7th step - Reboot

If you still have issues, share your display manager conf by executing

Code: Select all

 cat /etc/lightdm/lightdm.conf

---
As for this solution It might be overkill, and you can probably follow the arch page, and get success. If you add permissions.
--
album