ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] Problems with blackarch installation: error 404

Post Reply
User avatar
Phoenix750
Crewman
Posts: 8
Joined: Sat Jul 21, 2018 12:05 pm
Belgium
[SOLVED] Problems with blackarch installation: error 404

Post by Phoenix750 » Tue Jul 24, 2018 4:20 pm

Hello. After setting up ArcoLinux, I thought it was time to add the blackarch repositories added so I can get started again doing CTF challenges and such. I followed the instructions on this page (the instructions for installing on top of arch linux). After I ran the strap script, it output the following: pastebin (because too many lines).

After this happened I tried to do "mirror" and "pacman -Syy", still with no effect (mirror gave no errors, but pacman did):

Code: Select all

$ sudo pacman -Syy
:: Synchronizing package databases...
 core                                                              130,8 KiB  3,55M/s 00:00 [------------------------------------------------------] 100%
 extra                                                            1652,3 KiB  5,38M/s 00:00 [------------------------------------------------------] 100%
 community                                                           4,5 MiB  6,92M/s 00:01 [------------------------------------------------------] 100%
 multilib                                                          170,2 KiB  6,93M/s 00:00 [------------------------------------------------------] 100%
 arcolinux_repo                                                     20,6 KiB  1289K/s 00:00 [------------------------------------------------------] 100%
 arcolinux_repo.sig                                                310,0   B  0,00B/s 00:00 [------------------------------------------------------] 100%
error: failed retrieving file 'arcolinux_repo_3party.db' from arcolinux.github.io : The requested URL returned error: 404
error: failed retrieving file 'arcolinux_repo_3party.db' from www.mirrorservice.org : The requested URL returned error: 404
error: failed to update arcolinux_repo_3party (unexpected error)
error: failed to synchronize all databases
I run ArcoLinuxB-xfce.

If you need any more information, please reply to this thread!

Thanks in advance,
-Phoenix750

User avatar
erikdubois
Captain
Posts: 2120
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: Problems with blackarch installation: error 404

Post by erikdubois » Tue Jul 24, 2018 5:53 pm

I guess your pacman.conf must be wrong?

https://arcolinux.com/how-to-add-the-th ... cman-conf/
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
Phoenix750
Crewman
Posts: 8
Joined: Sat Jul 21, 2018 12:05 pm
Belgium
Re: [OPEN] Problems with blackarch installation: error 404

Post by Phoenix750 » Tue Jul 24, 2018 7:59 pm

Thanks for replying Erik. I solved the problem while waiting for my post to be approved, and indeed the pacman.conf was wrong after applying the third party repo. I'll leave how I fixed it down below.

So, the blackarch script assumes that you run "vanilla" arch and that no extra repo's are already attached. This is not the case for ArcoLinux ofcourse. If you look at your /etc/pacman.conf, you'll see that after running the blackarch strap.sh script, the blackarch mirror is attached to the end of the ArcoLinux mirror like shown below:

Code: Select all

[arcolinux_repo_3party]
SigLevel = Required DatabaseOptional
Server = https://arcolinux.github.io/arcolinux_repo_3party/$arch[blackarch]
Include = /etc/pacman.d/blackarch-mirrorlist
Pacman recognizes the [blackarch] as part of the Arcolinux repo, which gives our error. To fix, simply press enter a few times between the ArcoLinux URL and [blackarch]

Code: Select all

[arcolinux_repo_3party]
SigLevel = Required DatabaseOptional
Server = https://arcolinux.github.io/arcolinux_repo_3party/$arch

[blackarch]
Include = /etc/pacman.d/blackarch-mirrorlist

User avatar
erikdubois
Captain
Posts: 2120
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Problems with blackarch installation: error 404

Post by erikdubois » Tue Jul 24, 2018 8:48 pm

thanks for the feed-back
marking as solved now
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

onecore
recruit crewman
Posts: 1
Joined: Mon Sep 03, 2018 3:29 pm
Indonesia
Re: [OPEN] Problems with blackarch installation: error 404

Post by onecore » Mon Sep 03, 2018 3:31 pm

Phoenix750 wrote:
Tue Jul 24, 2018 7:59 pm
Thanks for replying Erik. I solved the problem while waiting for my post to be approved, and indeed the pacman.conf was wrong after applying the third party repo. I'll leave how I fixed it down below.

So, the blackarch script assumes that you run "vanilla" arch and that no extra repo's are already attached. This is not the case for ArcoLinux ofcourse. If you look at your /etc/pacman.conf, you'll see that after running the blackarch strap.sh script, the blackarch mirror is attached to the end of the ArcoLinux mirror like shown below:

Code: Select all

[arcolinux_repo_3party]
SigLevel = Required DatabaseOptional
Server = https://arcolinux.github.io/arcolinux_repo_3party/$arch[blackarch]
Include = /etc/pacman.d/blackarch-mirrorlist
Pacman recognizes the [blackarch] as part of the Arcolinux repo, which gives our error. To fix, simply press enter a few times between the ArcoLinux URL and [blackarch]

Code: Select all

[arcolinux_repo_3party]
SigLevel = Required DatabaseOptional
Server = https://arcolinux.github.io/arcolinux_repo_3party/$arch

[blackarch]
Include = /etc/pacman.d/blackarch-mirrorlist
Thanks man, i had similar situation with this.

User avatar
erikdubois
Captain
Posts: 2120
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [SOLVED] Problems with blackarch installation: error 404

Post by erikdubois » Mon Sep 03, 2018 5:38 pm

great
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “Installation of Software (pacman, AUR, ...)”