ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] Desktop not showing after login

bitje
Crewman
Posts: 9
Joined: Tue May 29, 2018 11:52 am
Netherlands
[SOLVED] Desktop not showing after login

Post by bitje » Wed May 30, 2018 1:37 am

Hi

When i login my desktop wont show. I see a black screen with my mouse pointer and thats it.
When i switch to another tty and back it works.

What could cause this?

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Desktop not showing after login

Post by erikdubois » Wed May 30, 2018 6:28 am

What system are you on and what did you do? :roll:
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

bitje
Crewman
Posts: 9
Joined: Tue May 29, 2018 11:52 am
Netherlands
Re: [OPEN] Desktop not showing after login

Post by bitje » Wed May 30, 2018 10:07 pm

Im on Arcolinux if thats what you mean by "system"

This is my lspci output:

Code: Select all

00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:16.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset PT IDER Controller (rev 06)
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82578DM Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Q57 Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
3f:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
3f:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
3f:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
3f:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
3f:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
3f:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
3f:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
3f:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
3f:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
3f:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
3f:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)
This happened after i installed nvidia proprietary drivers
I know i might be able to solve it with the nouveau drivers but i like to occasionally play video games and that works better with proprietary drivers.

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Desktop not showing after login

Post by erikdubois » Wed May 30, 2018 11:02 pm

That is the line that is important

01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)

Image

Not saying anything is not helping.

Did you try nvidia-390xx ?

Good luck.

Do your backups.
To the cloud with the folders and files.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Desktop not showing after login

Post by erikdubois » Wed May 30, 2018 11:04 pm

Always check the net before asking.

What about this then?

Go see on Arch forum

https://bbs.archlinux.org/viewtopic.php?id=229832

https://bbs.archlinux.org/viewtopic.php?id=199445

It seems there are more articles about this part.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

bitje
Crewman
Posts: 9
Joined: Tue May 29, 2018 11:52 am
Netherlands
Re: [OPEN] Desktop not showing after login

Post by bitje » Wed May 30, 2018 11:22 pm

Actually, this is the first time i ask help with something (together with my other questions here). I always figure things out for myself.

anyway

Did the following: sudo pacman -S nvidia nvidia-setting
This is the 396.24-6 version

Those links are not about the issue i have. I will read through them tho

I will keep searching for a solution. First ill try to disable "Forced composition pipeline" in the nvidia setting and see if that helps

bitje
Crewman
Posts: 9
Joined: Tue May 29, 2018 11:52 am
Netherlands
Re: [OPEN] Desktop not showing after login

Post by bitje » Thu May 31, 2018 12:17 am

Disabling "Force Composition Pipeline" and "Force Full Composition Pipeline" on both screen fixed the problem.
So composition seems to be the problem.

But, now i am plagued with screen tearing again so i did:

Code: Select all

$ xfwm4-tweaks-settings
to disable the composition manager and than i installed compton.

Most tearing is gone now but not completely so i still need to figure that out.

This problem is solved.

User avatar
erikdubois
Captain
Posts: 2010
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Desktop not showing after login

Post by erikdubois » Thu May 31, 2018 7:08 am

Some hardware is a b***

Good that you figured it out.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Rickyc81
Crewman
Posts: 16
Joined: Sun Jun 03, 2018 4:11 pm
Italy
Re: [SOLVED] Desktop not showing after login

Post by Rickyc81 » Sat Aug 25, 2018 10:33 pm

i've same trouble with

Graphics: Card-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 396.54

if i disable "Force Composition Pipeline" and "Force Full Composition Pipeline" tearing will come back.. :(

Ps. How did you set up compton?

Rickyc81
Crewman
Posts: 16
Joined: Sun Jun 03, 2018 4:11 pm
Italy
Re: [SOLVED] Desktop not showing after login

Post by Rickyc81 » Sun Aug 26, 2018 8:51 am

i solved with this workaround, it had come to my head, but then I saw that it was already used by others:
ive created a sh script with:

Code: Select all

xrandr --output HDMI-0 --auto --right-of DVI-D-0 && nvidia-settings --assign CurrentMetaMode="DVI-D-0: nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +1920+0 {ForceFullCompositionPipeline=On}"
put it in usr/bin and recall it on "sessione & startup", so, after login it make the change for ForcePipeline..

this setting is for 2 monitor..


Post Reply

Return to “Xfce-4”