ArcoLinux 19.09 iso has been released

[INFO] Printer support needed

Must read
Post Reply
User avatar
erikdubois
Captain
Posts: 2387
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
[INFO] Printer support needed

Post by erikdubois » Fri Jan 18, 2019 8:05 am

Many printers have support via a package on the AUR

General arch wiki info on printing - we call it cups : https://wiki.archlinux.org/index.php/CUPS

so use your terminal and type your printer type

yay canon
yay hp
yay ...

then narrow it down

yay canon-pixma

January 2019 we got an update and because of these updates more and more printers will become supported out of the box. No need to install separate drivers then anymore.

If your printer is still not supported after trying this. You can also try to add more drivers with this database

https://wiki.archlinux.org/index.php/CUPS#Foomatic



Install the blue hightlighted packages or even more to get your hardware printer support in.

Do not give up and search the net on other forums.

There is always someone else who figured out how to install your printer on an Arch Linux based system

Check arch linux forum, manjaro forum, etc...
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “Frequent Asked Questions”