ArcoLinux -D -B 19.5 iso's have been released

[OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post Reply
dbl.bzh
Crewman
Posts: 3
Joined: Tue Jun 25, 2019 9:47 pm
France
[OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by dbl.bzh » Mon Jul 01, 2019 9:59 pm

Hi guys,

I'm new on Arco Linux and i've some problems to configure my nvidia graphic card.

Here my "inxi -F" return :

Code: Select all

[dbl-lnx@dbl-pc ~]$ inxi -F
System:    Host: dbl-pc Kernel: 5.1.15-arch1-1-ARCH x86_64 bits: 64 Desktop: Cinnamon 4.2.0 Distro: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <root required> UEFI: American Megatrends 
           v: 3805 date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 2039 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 660] driver: nvidia v: 430.26 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz, 1360x768~60Hz 
           OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA GK106 HDMI Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.1.15-arch1-1-ARCH 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: 70:4d:7b:64:55:bf 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 3.62 TiB used: 1.72 TiB (47.4%) 
           ID-1: /dev/sda vendor: SanDisk model: Ultra II 480GB size: 447.13 GiB 
           ID-2: /dev/sdb vendor: Samsung model: HD501LJ size: 465.76 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB 
           ID-4: /dev/sdd type: USB vendor: Seagate model: ST1000LM 048-2E7172 size: 931.51 GiB 
           ID-5: /dev/sde type: USB vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
Partition: ID-1: / size: 95.62 GiB used: 25.50 GiB (26.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 325.82 GiB used: 188.28 GiB (57.8%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 16.44 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 10% 
Info:      Processes: 264 Uptime: 47m Memory: 15.61 GiB used: 1.82 GiB (11.7%) Shell: bash inxi: 3.0.34
The nvidia packages installed :

Code: Select all

[dbl-lnx@dbl-pc ~]$ yay -Ss nvidia | grep Installed
aur/gwe 0.12.3-1 (+5 1.37%) (Installed)
aur/nvtop 1.0.0-2 (+12 0.24%) (Installed)
multilib/lib32-opencl-nvidia 430.26-1 (13.9 MiB 72.6 MiB) (Installed)
multilib/lib32-nvidia-utils 430.26-1 (23.5 MiB 97.4 MiB) (Installed)
community/cuda 10.1.168-4 (2.1 GiB 5.4 GiB) (Installed)
extra/opencl-nvidia 430.26-1 (13.1 MiB 74.9 MiB) (Installed)
extra/nvidia-utils 430.26-1 (40.3 MiB 199.7 MiB) (Installed)
extra/nvidia-settings 430.14-1 (800.5 KiB 1.7 MiB) (Installed)
extra/nvidia 430.26-7 (12.6 MiB 12.8 MiB) (Installed)
extra/libxnvctrl 430.14-1 (76.2 KiB 502.0 KiB) (Installed)
extra/libvdpau 1.2-1 (56.4 KiB 303.0 KiB) (Installed)
This is my xorg.conf :

Code: Select all

[dbl-lnx@dbl-pc ~]$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 430.14

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.26

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer K272HL"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 660"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
#   Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, DVI-D-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
	Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    SubSection     "Display"
    Depth       24
    EndSubSection
EndSection
I've search in Arch Wiki Nvidia but no solutions found :s
I really do not know what else to do to solve this problem, so if someone can help me it would be really nice.
Thank you in advance :)

User avatar
erikdubois
Captain
Posts: 2120
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by erikdubois » Mon Jul 01, 2019 10:54 pm

I have no screen tearing on my Nvidia card but I do not use nvidia drivers.

Looking at this link did not help?

https://wiki.archlinux.org/index.php/NV ... en_tearing
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

dbl.bzh
Crewman
Posts: 3
Joined: Tue Jun 25, 2019 9:47 pm
France
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by dbl.bzh » Mon Jul 08, 2019 11:10 am

Hi Erik,

I'm sorry but i'm trying to switch to nouveau driver for try if i've the same bad performances issues.

Can you tell me how can i switch to nouveau driver and disable nvidia proprietary driver plz ?

Thx a lot

User avatar
erikdubois
Captain
Posts: 2120
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by erikdubois » Mon Jul 08, 2019 12:12 pm

Uninstall the nvidia driver and you will fall back to the nouveau.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

eesau
Crewman
Posts: 15
Joined: Mon Jan 21, 2019 10:04 am
Finland
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by eesau » Wed Jul 10, 2019 5:29 pm

dbl.bzh wrote:
Mon Jul 08, 2019 11:10 am
Hi Erik,

I'm sorry but i'm trying to switch to nouveau driver for try if i've the same bad performances issues.

Can you tell me how can i switch to nouveau driver and disable nvidia proprietary driver plz ?

Thx a lot
If you want to stick with Nvidia proprietary driver, put this command to auto start and i think you're good. Has worked for me in every Arch install every time.

Code: Select all

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
It's from the link Erik posted.

xeoncpu
Crewman
Posts: 61
Joined: Fri Nov 10, 2017 8:29 am
Location: Hungary
Hungary
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by xeoncpu » Thu Jul 11, 2019 3:33 pm

Hi!
Put this line to autostart !
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" &
if you on nvidia

or do 20-screentearing.conf in /etc/X11/xorg.conf.d/
and put in
Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Post Reply

Return to “Graphical Drivers (Nvidia,...)”