ArcoLinux -D -B 19.1 iso's have been released

[OPEN] Arco Linux on HP OMEN ce018np issues

lopoalmeida
Crewman
Posts: 18
Joined: Sat Sep 08, 2018 12:44 pm
Portugal
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by lopoalmeida » Sun Jan 13, 2019 10:01 pm

Bad news. Or sort off.

Only managed to install Cinnamon. All the other failed. Can't guess why.

Now I have an issue: I installed Bumblebee with instructions of Arch wiki and also nVidia Prime GPU Display. I followed the tutorial at https://evilshit.wordpress.com/2013/10/ ... rch-linux/ but I still get the following errors:
  1. On the Cinnamon spice it says

    Code: Select all

    nVidia Prime is not setup - nVidia drivers are not setup
  2. Code: Select all

    cat /proc/acpi/bbswitch
    shows

    Code: Select all

    0000:01:00.0 OFF
  3. Code: Select all

    optirun glxgears
    returns:

    Code: Select all

    [ 1943.130631] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [ 1943.130713] [ERROR]Aborting because fallback start is disabled.
  4. With

    Code: Select all

    sudo systemctl status bumblebeed
    it returns the following:

    Code: Select all

    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
       Active: active (running) since Sun 2019-01-13 21:39:05 WET; 13min ago
     Main PID: 536 (bumblebeed)
        Tasks: 1 (limit: 4915)
       Memory: 2.5M
       CGroup: /system.slice/bumblebeed.service
               └─536 /usr/bin/bumblebeed
    
    jan 13 21:39:05 laptop-omen systemd[1]: Started Bumblebee C Daemon.
    jan 13 21:39:05 laptop-omen bumblebeed[536]: [    5.468353] [INFO]/usr/bin/bumblebeed 3.2.1 started
    jan 13 21:50:35 laptop-omen bumblebeed[536]: modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.20.0-arch1-1-ARCH
    jan 13 21:50:35 laptop-omen bumblebeed[536]: [  695.854039] [ERROR]Module nvidia could not be loaded (timeout?)
    jan 13 21:50:35 laptop-omen bumblebeed[536]: [  695.854081] [ERROR]Could not load GPU driver
    jan 13 21:51:26 laptop-omen bumblebeed[536]: modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.20.0-arch1-1-ARCH
    jan 13 21:51:26 laptop-omen bumblebeed[536]: [  746.385584] [ERROR]Module nvidia could not be loaded (timeout?)
    jan 13 21:51:26 laptop-omen bumblebeed[536]: [  746.385623] [ERROR]Could not load GPU driver
    
Uisng

Code: Select all

sudo echo ON >> /proc/acpi/bbswitch
does not work. Gives

Code: Select all

bash: /proc/acpi/bbswitch: Permission denied
Don't understand how to solve this. It seems that all the needed software is there but somehow something is not properly configured :\

lopoalmeida
Crewman
Posts: 18
Joined: Sat Sep 08, 2018 12:44 pm
Portugal
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by lopoalmeida » Fri Jan 18, 2019 12:45 pm

erikdubois wrote:
Fri Jan 04, 2019 9:07 pm
You can compare the builds of all iso's on github.
Although I didn't manage to make NVidia work all was more or less fine. Now, after a normal update the result is that it boots, check the /boot at my SSD drive as usual and mount the partitions. All fine but after that it freezes in a screen with a blink cursor and that's it :\

It seems that it doesn't load anymore the X server or Light DM.

I can get into the system using TTY2 and run commands without problems. System says it's updated.

lopoalmeida
Crewman
Posts: 18
Joined: Sat Sep 08, 2018 12:44 pm
Portugal
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by lopoalmeida » Tue May 14, 2019 2:34 pm

erikdubois wrote:
Fri Jan 04, 2019 9:07 pm
You can compare the builds of all iso's on github.
Meanwhile, I installed Pop_OS! because it was the only one that booted without too much fuss.
Unfortunately, I had to reinstall it due to a problem with EFI partition size and the way Pop_OS! deals with boot files (duplicating some from /boot to /boot/EFI) that borked completely my system after a kernel update. It trashed even the part of Windows 10.

So, after repartitioning my SDD and recovering Windows 10, I decided to give it another try with rolling releases, and for me the better is still ArcoLinux, and test it with your last version.



As you can see in the above picture, last version of ArcoLinux D (19.4), whatever flavour, won't boot at all.

Tried AntergOS but it has some itches too. Manjaro is the only one that boots flawlessly and in the below image is what they have in the boot options.



But I noticed that they call two extra files that ArcoLinux doesn't use.

Questions:
  1. Can I use the same options with ArcoLinux? If yes, how?
  2. As an optional solution, can I install Manjaro as the base Linux and them move to ArcoLinux with the scripts? If yes, how?
Thanks in advance

JustaBob
Crewman
Posts: 5
Joined: Thu May 09, 2019 7:48 pm
Canada
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by JustaBob » Wed May 15, 2019 2:10 pm

Try adding to your boot line:
acpi_osi=! acpi_osi=Windows i915_preliminary_hw_support=1

oops, typo!!!
acpi_osi=! acpi_osi=Windows i915.preliminary_hw_support=1

note the dot, not underscore.
Last edited by JustaBob on Sun May 19, 2019 12:06 am, edited 1 time in total.

lopoalmeida
Crewman
Posts: 18
Joined: Sat Sep 08, 2018 12:44 pm
Portugal
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by lopoalmeida » Fri May 17, 2019 12:59 pm

JustaBob wrote:
Wed May 15, 2019 2:10 pm
Try adding to your boot line:
acpi_osi=! acpi_osi=Windows i915_preliminary_hw_support=1
It worked. At least it boots. Lets see if it installs and boots from HD also :)

User avatar
erikdubois
Captain
Posts: 1843
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by erikdubois » Fri May 17, 2019 8:23 pm

Do not leave us hanging...
Others can benefit from your experiment ...
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

JustaBob
Crewman
Posts: 5
Joined: Thu May 09, 2019 7:48 pm
Canada
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by JustaBob » Fri May 17, 2019 8:29 pm

I found those are required for my linux systems with the fancy nVidia/Intel graphics from different manufacturers.

The acpi_osi ones fix the boot and the i915 one fixes problems suspending and resuming.

I found that different kernels may or may not require them, and in those cases, if I see an error at the boot on one of them, I remove that one.

xeoncpu
Crewman
Posts: 52
Joined: Fri Nov 10, 2017 7:29 am
Location: Hungary
Hungary
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by xeoncpu » Sat May 18, 2019 2:26 pm

Try this at boot :D
modprobe.blacklist=nouveau

JustaBob
Crewman
Posts: 5
Joined: Thu May 09, 2019 7:48 pm
Canada
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by JustaBob » Sun May 19, 2019 12:10 am

I booted my Dell Inspiron XPS 15-7559 with Arcolinux 19.04 by adding the string below to the boot line after hitting Tab to edit the line from the boot screen. Without it, it failed to boot, with it, I'm running fine, typing from it now. Manjaro will not boot at all no matter what I tried.

acpi_osi=! acpi_osi=Windows i915.preliminary_hw_support=1

lopoalmeida
Crewman
Posts: 18
Joined: Sat Sep 08, 2018 12:44 pm
Portugal
Re: [OPEN] Arco Linux on HP OMEN ce018np issues

Post by lopoalmeida » Sun May 19, 2019 1:11 am

It boots adding this:

Code: Select all

acpi_osi=! acpi_osi=Windows i915.preliminary_hw_support=1 driver=free noveau.modeset=1 i915.modeset=1 systemd.show_status=1
Going to test removing parts of it to see what makes sense and what doesn't.


Post Reply

Return to “Installation issues of ArcoLinux iso”